open mini netbook

open project of mini netbook, 7'' ARM netbook

You are not connected. Please login or register

anyka 7802 black screen

Go down  Message [Page 1 of 1]

1 anyka 7802 black screen on Fri 16 Dec 2011 - 12:52


I have mini laptop noname
Anyka AK7802PQ21605
nanya nt5ds32m16cs 5
ROM v.1.83
after upgraded nonstarter
Sorry for my English google translator!
I need ROM v.1.83
thank you

2 Re: anyka 7802 black screen on Thu 22 Dec 2011 - 8:38


Which ROMs did you try?

3 Re: anyka 7802 black screen on Thu 22 Dec 2011 - 10:51


otoluk wrote:Which ROMs did you try?
not help!

4 Re: anyka 7802 black screen on Sun 25 Dec 2011 - 1:10


Mine boot with 1.63 but fails when initalizing lan ?
Wont boot with 1.9 ? What can it be and has somebody has 1.83???

5 Re: anyka 7802 black screen on Thu 23 Aug 2012 - 3:11


Hi there,

I encountered the black screen problem or the problem that the machine became bricked as many folks here did.

I also tried all the ROM versions
1.63, 1.82, 1.87, 1.9, but in vain.

After careful study of the config.txt file in the BurnTool, I finally came to the conclusion that my main board was NOT SUPPORTED simply because the board carries the NAND flash marked "H27UAG8T2M" which is not listed in the config.txt file. I also found another main board that carries a different NAND chip "K9GAG08U0M" which in included in the config.txt, indicating that it is supported. The latter machine never becomes bricked.

SO the key issue for the bricked machine becomes very simple and very tough: How can we or anyone upgrade the BurnTool so that it supports the Hynix chip?

I tried to add the chip to the "Nand Supported Count" list, the added line reads like:

nand75 = 0xADD514B644, 4096, 128, 2048, 4096, 2048, 128, 2, 15, 3, 11, 0x2, 0x10000001, 0xf5ad1, 0x50303, Hynix H27UAG8T2M

Unluckily, it failed again.

Anyone has a better solution?


6 Re: anyka 7802 black screen on Mon 27 Aug 2012 - 14:32


From whre did you find parameters for H27UAG8T2M/H27UBG8U5M/H27UBG8U5MTR? You need to provide correct ChipID/FID(0xADD514B644). The table can be edited from burtnool->Settings->Producer password Anyka.

The ChipId needs to be provided byteswapped and only first 4 bytes in config.txt - so ADD514B644 becomes 0xb614d5ad. I found that it is already provided in my config.txt

nand45 = 0xb614d5ad, 4096, 128, 4096, 4096, 2048, 128, 2, 15, 3,  11, 0x2, 0x10000001, 0xf5ad1, 0x41313, Hynix H27UBG8U5M

of course maybe some parameters are wrong but often the netbooks get bricked because ROM is different. You could try to delete this entry in config.txt or modify and see waht happens. I think that it flashes correcty just ROM doesn't fit.
What was the original ROM version?

Last edited by otoluk on Tue 28 Aug 2012 - 11:14; edited 1 time in total

7 Re: anyka 7802 black screen on Tue 28 Aug 2012 - 2:31


I found the chip data at
But the Table says that the "chip is not detected properly".

By the way, the chip H27UBG8U5M which you mentioned is rather different. Let's compare the two:

------------------- Density --- Block Size --- Stack --- Vcc/Org

H27UBG8U5M 48nm 32Gb 512KB(4KB Page) DDP 3.3v/X

H27UAG8T2M 48nm 16Gb 512KB(4KB Page) Mono 3.3v/X8

I wonder if anyone has ever succeeded in flashing this chip. It is likely that it is written with a programmer before it is mounted on the mainboard.


8 Re: anyka 7802 black screen on Tue 28 Aug 2012 - 11:14


You could try. But what do you mean that it fails? It doesn't flash or it fails at booting after succeded flash? What was the original ROM version?

There is problem for ak8800 devices which doesn't flash also I could check the topics which flash chip was used in there.

AK8802 netbooks come with these flashes but ak7802 burntool doesn't work on it(init failed error). There is no ak88 burntool except the one .exe I modified which still doesn't work:

H27UAG8T2MTR (I have this on my ak7802 netbook and flashes correctly)

Sponsored content

Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum